WordPress「PHPの更新が必要です」(ロリポップ)→PHP7.3に更新したら直った

WordPress「PHPの更新が必要です」(ロリポップ)

WordPressの管理画面・ダッシュボードにこんなメッセージが。

❗️PHPの更新が必要です

サイトが安全ではないバージョンの PHP を実行していることを検出しました。

PHP とは何ですか ? サイトにどう影響しますか ?
PHP は WordPress の開発や保守に使用されているプログラミング言語です。PHP の新しいバージョンはより高速で安全なため、アップグレードするとサイトのパフォーマンスに良い影響を与えます。

Wordpress「PHPの更新が必要です」

サーバーはロリポップ、PHPのバージョンは7.1(CGI版)です。

なんで?結構新しいよ?と思いましたが、同じサーバーに置いていいる他のサイトでも同じメッセージが出ていました。

どちらのサイトもPHP7.3(CGI版)に変更したら10分でメッセージが消えたので載せておきます。

① ロリポップ管理画面 > サーバーの管理・設定 > PHP設定を選択

②登録しているドメイン一覧が表示されます。まだ5.2のドメインがある!w

ドメイン一覧が表示されます

③プルダウンメニューからPHP7.3(CGI)を選択し、変更。
(WWWあり・なし両方行う)

プルダウンメニューからPHP7.3(CGI)を選択

④10分ほど経つと更新メッセージは消えました。

7.1(CGI版)ってないか脆弱性があるんでしょうか。よく分かりませんが通知が消えてすっきり!

こちらもどうぞ! [2020年8月] 人気SNSユーザー数 – Popular Social Media in Japan